Errors when installing lme4 for R version 2.15.0

Tuesday, June 26th, 2012 by hinrich

R

I have just moved to R 2.15.0 and needed to make use of the R package lme4. This kept failing for me with the following message:

/usr/bin/ld: cannot find -llapack

Initially I tried various ways of loading lme4 from R-forge, CRAN, ..., but eventually I stumbled over the comment that I may have the run-time, but not the development packages. So installing those via

sudo apt-get install r-base-dev

did the trick. Now lme4 works!

Posted in Misc


Categories

Archives